2009년 6월 18일 목요일

FreeBSD 7.2 + Flash 10 + Firefox 3

Recenly I had some problems with my FreeBSD installation. I had to come back with 7.2 installation after upgrading to -current, it breaks my X windows.

BTW, I'd like to talk about FreeBSD 7.2 + Flash 10 (linux) + Firefox 3. It's very easy. You can find similar instruction for Flash9 in http://crnl.org/blog/2008/11/01/flash-9-for-freebsd-71

0. Config change

In /etc/make.conf, add

OVERRIDE_LINUX_BASE_PORT=f8

In /etc/rc.conf, add

linux_enable="YES"

In /etc/sysctl.conf, add

compat.linux.osrelease=2.6.16

In /etc/fstab, add

linproc /usr/compat/linux/proc linprocfs rw 0 0

Install this ports

emulators/linux_base-f8

Run these commands

# sh /etc/rc.d/abi start
# sh /etc/rc.d/sysctl start
# mount -a

1. Install ports

www/firefox3
www/nspluginwrapper
www/linux-f8-flashplugin10

2. nspluginwrapper configuration

# nspluginwrapper -a -v -i

3. Run firefox3

# firefox3

You should see "Shockwave Flash" section in about:plugins URL.

That's all!
댓글 쓰기